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II‘ Learn in English

The menus are context sensitive. This means that those menu items are
available that are relevant to the work currently being carried out. If the
cursor is located in a text, then all of those menu items are available that are
needed to edit the text. If you have selected graphics in a document, then you
will see all of the menu items that can be used to edit graphics.

File

These commands apply to the current document, open a new document ,or
close the application.
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Edit
This menu contains commands for editing the contents of the current
document.
View
This menu contains commands for controlling the on-screen display of the
document.

Insert

The Insert menu contains commands for inserting new elements in your
document. This includes sections, footnotes, notes, special characters,
graphics, and objects from other applications.

Format

Contains commands for formatting the layout and the contents of your
document.

Tools

Contains spelling tools, a gallery of object art that you can addto your
document, as well as tools for configuring menus, and setting program
preferences.

Table

Shows commands to insert, edit, and delete a table inside a text document.

Window

Contains commands for manipulating and displaying document windows.

Help

The Help menu allows you to start and control the OpenOffice.org Help
system.
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23- To protect the cells from being changed / viewed / printed according to
your settings in the Format Cells dialog box, choose .............
a- Tools = Shared Document
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24- Which Menu contains spelling tools?

a- Format b- Insert
c- Tools d- View

25- For Inserting new elements in your document, use ........ menu.
a- File b- Edit

c- Tools d- Insert
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II‘ Learn in English

Use the Unfiled Notes section when in doubt

When you don't have time to think about where your notes should go, just
click Window logo key + N which immediately launches OneNote and
creates a new page in the Unfiled Notes section (click the button at the
bottom of the Navigation Bar to jump to it later). It's okay if this section gets
big. You can drag the pages to other sections later, or just use search to

find them in this section.
Unfiled Notes section
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10- When you don't have time, where should your notes go?

a- All Notebook List

b- Unfiled Notes Section
c¢- Personal Notebook

d- Work Notebook

hos 9037

C dwas? 5 € casei? glapls 4o Glize o g0 L «Blaah sl 4y cblosly ax mds S )
oS sl

o ool Jlo zn 0 4 deass Blaal Jols Jgom o gl amio o € Loasi» isu 0 =Y
o lad)s s Slaal 5l Sope a4 v, $ln &S]y (Slej g 00,5 sl sl i wy)ls
2 5y blie (5

S eolaiwl canlin slacinz 3l Blasl cand o -Y

L adaly )0 (5 paibue gdgs 5 00,5 sbml jasin b b glaillas axio (Slaal 5| Sy 6l -F
IRVELIRA PR

S T8 E9dge b b e gl (Dl 5 (o s (Bl -0

S ot i s 44 35 € kD i 3 F



oow )5 salg

SharePoint ,13¥1p y b |5 01

(cssbas) (oo

sles gk

Y o /0

A O VYK

1S 3 gy o0 YUAIN) yaS) 48 5 HIS aal g (pl dadlas ) gy
Bl o culas 5 adin o gde )

il Ly SharePoint 138la 53 IS laas by =Y

oS slulis |, SharePoint )38l 53 caliss slalas -V

&S S SharePoint ) 38la 5 cafiae gla) b Wil g —¥

A gl sobel sl &I 5k 3 sules culus s S -0




oMl ol ) 5 Saa s =5l @M 5 8 olesla — elaial sl 5 IS ol
sy LIS G e lailie als @ Sl3la s S it als Y ).

15T aalllas 10 jlach Y-YY/YY/\/Y co,lach

wlls
W SO0 leds aS 0 pbejlu as e &g a1y Oledlbl aS conl Glazis g axio
b ol aman S 4 58 Gl g aes o 18 s L es e il O g0 4 1) Sledbl Word
L e SO (59 Sl (BLS il s f O 4 Sledlbl ST Ll aples joye 1) Sledbl IS

g s 0d—el (Hyperlink) cyio pl cailily Jlo)55 50 s 8 cadilojle cools 5l as olaiyise

S p3Y ol joas el g lele plan el Lale cal oo Ly el 5 g Slxas il
Digd 035l ambo G 40 g o0 JLid a4 SllS den liig i Lle ailes

1y oyl 5l glite SalS omms g 45 S b Lol ectunsl 62l et g 2 o S5 Lo L5
S (58 Joe 00 1S gy = 00 (g

b Oyge a4 o Sledbl a8 e 03V wigd oo oy w4 ool Abiasy 4 0yl 5z
5 o olxio 1) o slaoel, a5 el Jlacgs GLF S g (ool Pl ;o ail snd Cipe

Sed Calan gapar Slxio 4 o] ! b Wiy e IS 45 sl oy bli &0

Yo\ JSdh

f)/w 4SS Wgd o 03l iulad glofg bl & jg0 4 laaign (Browser) g 59,0 jl38le 5 50
aS oy bl pl Gl b Wlgh oo )5 g s Lo y5 50 s glilo g Sglate S5, L ooy
Lo S0 ol S 058 Colas Silorio &) 00,05 0 90 bag)T (55, sle SIS eolical L 1251
=6 HTIML (yie ol g 135 ade (Lsj 5l eolaiwl b asg (e pl Slmio diun faio oy



eSS bl slasldle 55 i Sl dalasy
SharePoint ,153la 5 b LIS : Ll g3

"W
HTML &l g 0,5 o,l5 g Notepad aiile cyo ool [Sinl g G sl oolaiwl b Jay gl o
. 036 )‘9.».'50 9 Lot 6)5 Q‘).!)ls t.g‘)'.' s g PLY @L‘?u" )‘ RGIEE I g 4o S5 0‘5"@

L L oa,S slice o8 oidgd 5l 0ln)l5 j9aig Jele plapns o5 a5 sl 2Lk ola )l 5

-9 QU,Q,WV—‘

Ol el K0S L la e g Jitne gla b 1 glaegazea (o] UK o osls o Cuoliscy S
So Sale 5 52 025 (o0 B oimd g e FomeslS Sl (patine sLaS (9)0 Lo L acsee
Sl ggals G5k ) a5 (olfin GEaS OB 0)ls (pgasie 0j9> pl SG g 3 34 pamis Jlis
ar Saliwoy Slodlbl ans gl cnlssys S e o)ly g T h55e o 1y Gl Ol pasie
B9 se Jlo)l Colbog 0aiad gy SgalS

Jlw,loauS cevlgz jo Sl S a1 a0, Sledbl 5l S SO 0020 gy 5 gamalS
Sl Edge aladlo )0 SglST SIS 5 00im ) 0 1S gy FomslS 4 DA (pl S (oo
IS 4 g oad yuds Sledbl ol dnternet Explorer ol )5 g 00 doli o oo 5 00l
Bgd oo T 00515 ialed amio (59, g Dlbo

S a5 ol oSBT 5 e s sMesarme Jolt o] S (ool 55 oy dmis Sy
o3l g S le g Glras Oy0a ol Jb o aldl Wloads (5,505,5 axly OB G (9,0 a5 el
S oledsl wiyol8 g s Lgy g Solns slaceond @ pome (55T g Oliws SR I
Slio cole Gl wims al)l ca SO 4 1) Slas 5 Sl Hlojen 5 00,5 Cdl 0 )l
S o 4385 SaS g Slomio il gl 3l 51 Ygane olS gl g S b g

45 3gai 4s e |, FrontPage (5 |5-3ls 5 iy by, Sole o5 ,0 N AAY Lo 5l jelais ol (6l
355 ooy 53 5 99 HTML (sla Saazey 50k 2 5L5 (9 g Slomivo il gl ol (o0,
) oy ambo S ozl FrontPage .owl oo )leds & laz 10 6)l38lp 5 OV game o g 51 (SO
Sy e 5 ol Cdlug Sole Ve o o Sl 50 090 00505 ] Word o aali G (yitigs i
g olbls )| lez 4K Coanl Sl 45 5,5 4 ,¢ Offfice degazes

W slp ale; cnl o se 05500 Jlada 0y0)9, )15 wos 5o LS 10 Sledlbl ols 1,8 055 5l
5 98 g sar g Calew Gl 5, o S (e 00liil s j8 5 (63L bL3 ) (B350

G5 6ol; oS il Sole o S0s Vs 5 Vs ol bl is 5 o g3l e o



oMl ol ) 5 Sia 3 eyl @laa 5 8 losl — elaial H sl 5 S ol
58 ety LIS G il als Sl S13la 5 5,8 il als )\ Y
ol dalllas :o jlach Y=YY/YE/N/¥ 0 ylad

4 g o algie FrontPage asl p as e YooV Jlo jo canl il Oy Olxiao ok sle )8l
2Le3 SharePoint 2007 .3 Ll Expression Web 5 Office SharePoint 4l g5 1 sl>
sleslaiul (6,50l aullo [y WWW ol SO o oo 5 i oloul gl o3V sla 3!
oo aoby o a5 pl b el Office acgomo gloasl p S0 3l eolaiul (5,50l aiile SharePoint
szl sl Word 5ls,me3ly 51 ST .ol Lol jlaws oy 51 Slesia soliiwl Lol oo ls calisee Sl
I, <9 olew! g SharePoint 3| ool ! sl g3V slacs )l yiiion (il 00 )5 oolawl ool 4l

Dgr dadles o

MNP P o b (LT g i Y-
sl l38le 15 ol an 4 SharePoint cel 1 Sas 0iS' o 03lizwl CD 5l Office acgooms caai jo 51
DVD JJG o o] 5 an Office 2007 sla 33l 55 ol pan> 5 slawd Cle a4y 0580 Ceal w90

S oolaiwl Office 2007 acgoze DVD
SharePoint 133105 )2l ¥-Y-\

Jlis Y=Y UKo b ilhas |, 05 U= SharePoint l58le 5 szl jsbate s ojl8las caci 5l o

e I
£} Mooech Ofce Tooh b8 ] Mool Difcs Took '

B tacrcsoh Frovhase e
E Pl gl sl g T
IS Farcah Fusl B Mol Do e J000
o
I
Ly

S B Offeon Ao SO0
el P i Y
B moost Prsseport Miceoctt Offios InfoParh 2007

B oot o ! Ml O Cresdiols 207

PR i L e B0, 1 wll L5 el SiVa P R0

[5) Pl Inigemat Priniry ol Mosoel Qifios Publahes J007

F-'j due ol Crtilew & 1 b= kel e e TGS

B Aok dcrobast . § Profyssmonal . lcnoai’ Cifaos vien BT

) *3D Sretwwa L] 8 Mol Difios Projed IG0T
Sp— N r—

et i i
) W

) bk Posssrlal i
=) CybeLink PrweerTND: Copry L

SharePoint dols y (51 2l 0 923 V=Y S




A4S SIS Start aeS's (59, —)
Awled ol 1) All Programs a5 oads 5L (g0 51 =Y
A4S SIS Microsoft Office 438 g5, -V

S ol |, Microsoft Office SharePoint Designer 2007 435 oo 5L (g5 51 —F

SharePoint doU 3 Jou=xo Y'-Y-Y

g n 03l Liled Y-F IS gllae (slasio sl (gl )z 51 uy

SharePoint dols ys laans Y-V S

Hlaile a5 W5l 0929 (0,8 i Dyge A (oo iy odld oold isled axans (o

aS 05,8 18 gglate sledlgy o Wil oo g Dlxas (Folder List) balgy o
g g0 03l Gislad ddliey Concd o

O |y Ol jgiws slodasin olgi oo 0,2y () ;o (Tag Properties) olgs o iy
pgas o8 SS 6l Mo 3,5



ol bl 5 Sia 3 eyl @laa 5 8 losl — elaial H sl 5 S ol
58 ety LIS G il als Gl 15805 5,8t lailied als YV F

ol5T dalllas o Lok YoYY/YE/N /¥ o ek

ol dsd Olxao >l e Untitledhtm (6,8 o s Loy pl i 2lb oy @

ul.?ubo 6..\.~su.ll3 9 Q’““"‘)"ﬁ 6|).s U‘?"(SA o):;n..; U"‘ )‘ I(TOOlbOX) )‘}.?' 4.’.2.? 0).7.5;.1 °
el S 0,5 adlsl e oS dilal Lg asao w | p3Y 0 lee g D50 oolail

2ol lso,S bl ol slacSw g5 o (Apply Styles) b Suw oyxiy  ©
Lz 0y o9 Slxas L,>_'>|)Ja o oslal sl 1L o5 solaiwl Slxas u:'-’l)"a

o ey oyl 51 G o Task Panes g0 b View (ggio 5wty IS glasd bl sl oles oo e @
(V-0 5 ¥-F sl i) 5,5 Jled,e |,

Task Panes [
«  Folder List
Mavigation

»  Tag Properties
C55 Properties
Layouk Tables

~*  Apply Styles
Manage Styles
Behaviors
Layers

v Toolbox
Daka Source Library
Daka Source Details
Conditional Formatting =] i
Find Data Source #] Page 3
wWeb Parts
Find 1
Find 2
Accessibilicy
Compatibility

Page Size b
Hyperlinks

m |

Folder List  Alk+F1
55 Reports

]

Mavigation Pane

g

Clip Art

Clipbaard
Toolbars 3

Reset Workspace Lavout

02 Soias $Lac o (ja,S Jlad yul ¥-0 Y View (5 930 Y-¥ JSub



SheSS solal slasln8ta 55 1 S ylee dilasy

o SharePoint ,153la 5 b LIS : Ll g3

o laitwl il les o (Menu Bar) g jlss (Title Bar) lgse (g9 oy ogdle Sy
oo aslsl gl sl )8 ama s ol o (Status Bar) cossg lss o YU o (Standard Bar)
3y 00,5 cenly SIS aa o YL JIB ahass G p0 lgs oo lrgie (S B> b was slagie
a ;S Sl View s 51 LS Gl andl o7 o5 L adlal ) olgsds (sl lgs conds 5l (520 2

(V-7 JS8) el s Sl 5.5 Toolbars

Skandard
Formatting
Code View

¥ Camman
Dynamic Web Template
Master Page
Pictures
Positioning
Skyle
Skyle Application
Tables

Task Pane

Cusktamize. .

Clids (5La,lgh GuS 3Ll b 3a ¥oF Jsud

SharePoint )l 3810 )3 ilixo slales ¥'-¥Y-Y
55l aas)le aS o 1o 5924 Les 4w SharePoint l53ls 5 jo

b aldas (g co sl (B,8 i Oya0 @ a5 L ol yo (Design) ok glos @
Bl plxl o iy g gl SS a0 |

5 AS g ot S S d 90 Ay >l b axas Loi (pl )0 (Split) sussSTas glos @
Y-V JSo) oyls jl 3 ok sled ool Caond 10 5 cmngiadS isn YU Cond

35,9 St 45 39 oo LD s giaS 0y add Lo cpl 0 ((Code) owoginS glos @
g oo oolaiwl oS



(Split) ouias Jua (slas V-V J<ub

395 90 51 oSI 31 ool b Culwrg o1 b V-
Cilize Slacal U amio cpaiz 5l cole S Ygane a5 ol wib wolosy o (>lb plkin 5o

A o iwd ;0 o5 aS 8 ls 59> (Homepage) Lol axio O Jooro job 4y 09 o0 JoSis
slaig 5leolatwl b g Lol amin &,k 5l aigh oo axlse T bl 0wl a8l (55, <olo
)5 My (o S50 Slagle (2 b culs S0 Slmio 4 ol o0 <0 00950

(=353eD) oz Caliwsy Bon 08 e 4 Sl nl Coliiog S (AL s gl po8 ey
72 9950 eSS Ao wiz l Cule 45 955 (et b e (o b (gated ( Glo oMbl s )l
fo5 fate ;500 Ol 4 a3gSs ¢ all aiils Slgiow 4> axas

gdhge Wbl Cole 0y Ko (b (SiSz b an Jle

S8 Colis Oy cpl S A Coluay SO 0s3 e e sl au s aal asS (5,81 JME
Sl oS QLS Gl 5 G (b3 68 Gl el v a (Free  ogdle ol
A jobb 4y o b ails ol e 1) 0,08 g pie sl



eSS (551l (sla 8l 55 1 lee dilasy

ny SharePoint ,153la 5 b LIS : Ll g3

o, dlol gluy Bas

§ sy Ao (et (S0l g, dotio o B pre dxans (Lol s Juld axio A ilras olaxs

obal 5 B uSe amio L3 axio (b lacols (e axio uly

Db Slrrs dar (49,0 3105 Tay cwiwd 0ol SO Slbao 4 g8 oo ol s 5,

Sges dal g Cd,y Sl aby 4 lg

0S 0 ool o5 4y 85 & 50 4 SharePoint 1331 ¢ 5 solel (slagSIl 5l co3s, cnl sl sy
JSs 5l pleeil b oS’ Gl |, Web Site... aibj w9 New ai 35 File g5 51 -)

D9 oo o3l islad Y-A

Page | Wb SEn
e e e ek e Drctirdun
__Jl'.mr“‘-h"dﬂ- el & Fowe Wi S0 vl & SO Duile
5 L ool ___']11;..'."'#-{.1-“':&': (A
el e e
e o
Tpacily the e adion of thes ress Wish s
RS el e Sl LA My Doty Wieds Sl i e ila 13 S | o |
- m— -
I L | | Carsal

oulal (5 o3 Bayb 3 Culs g b ¥-A Y

(V-9 J8) swsles ool |y Templates 435 Web Site ... aiby 5l ¥-A S 0 =Y

5 eash o glojlu aiws aw ;o a5 3,10 8gzg laculu ‘5>|)Ja oole! S-S o Y
Y-V JS) oS ol 1) OrganizationS a4 33 .ailoas gonaab (g,



| Cmsagiten
Croate 4 Web sRp i e crparataton o
chubi.

Seedly i lotabon of He fas Welb sl
e e e .. -___.-_.-_HI“-"“-" - -i.

!'FE!IT% i

L
:

Organization5 (g 611 QLASAI Y=\ v S



)_Sé b)‘yc la Lg‘ ML aslas S92 Lﬁ}ij‘ Lo )lef $9) oAl cuas )‘)ﬁ‘,B)J BN Sl uSM :“@
Awoles oS Office l38ls 5 Templates asigy jo 1) lagSl ol & jg0 ol Ho 0l Dol oals

S5 4y 0l Alwlgm Olras Cl ol (b Col 05 S cads oYY S o -F
(Homepage) ol axi o .l 48,5 )| 3 Folder List ;o 555 alg ;0 G ;0 g ol
oled o sl 1,845 L col 6531 L p,T .ol Defaulthtm ol a5 Lod ol o
J=b ;! Master.dwt (gg, .l 48,5 |1, 8 Master.dwt o8 0 043 |1, S5 Slao
V-V JS) 05 50 o sl al; G ol pg amio o b oS S Lls Folder List

Organization

IBigpariidabman [oaa i ijslinis

Reading 2

L le o L ]

Master.dwt Jald ¥—\\ <&

5 ol g9 dnles Galng 055 olgsds | bagT il g axmiio (9,0 Slacie (55, SAS L -0
(Y=Y U8 cl yoss LB Office acgooms slo)l38ls 5 iy aslice ol ol



WU g 3T eI i

i

B ot 1

- e E T
T u--;-r].-f—':,r:w.»--p-'----.--

=t ptapng g ! et | i e

Master.dwt Jsl8 (il ju 9 Y-V Y il
LS Save 4 wSs 55, SdS L oS 0,58 | Lol wcal o3Y wl o plil 51y —#
08 )5 i Olrao 4y Audly g Olras plod (59, Ol s Jlasl a5 065 oo 5L (slojgloxe
U"LA—:" d.aL?‘» ‘SAL) o0 P‘.?u‘ Q‘M aQ 0‘53‘5» l>‘)g“ OO AR (0 )‘)3 Ot 3 590 ‘)
V=V U)ol aales 0058 (LS LB (65, Ol poss & jge ol 8 0 0l

Embesddad M e sais Pt s

hiai-eraegs Lhe 1odess Faad

[ roem | [ wmrie. | [ senn. | [Fomrtos. |
—

sk aladl &l yuskd 0 a3 P\ F- 81 S



@ Tharm arw £ il atschasd By ‘mapher e, ol oo e Ho updabes T now?

S S (59 1 pad3 0 s a B Y- VYo S
S )T s s s aalys o] i plas (55, s Yes 4335 (53, SlS s -
(FVF US5) 858 o )55 gl Slovio solas 5o

Cules Siladis golai &l i Jlas ¥V F JSud

sleyie ol b oS 5k QT ol 55, SIS Lo b 1) Defaulthtm Lol axio Jl> —A
SACATANE W) IRVEL Y QT ol 1y elesds slaiyie waxian 1o

Wby s g1 P AR e

gl 18 s
e T el e R e e e
1
|
L
_...I- :'cl.-. - -

Culwo g Lol dadis il ju 9 ¥-V0 Ui



oM oL ) 5 K3a s il s g 38 Gagfn = lFel) yodl o JS @y
8yt IS S it als ol I3l IS lailieal als Y YY
o5T dallias 20 lack ToEY/YE/N Y o lad

oLzl |, From File a8 Picture (59— 5 Insert (go—o 3l pgas 0,5 adlsl gl -9
S SIS Insert a oS (g5, 9 olsil canlio pgal SO wads 5L o glxe 05 o asS
(Y-8 o)

Lo L e s = & ¥ uil-
—
Card 4
' s m—_ced Kb S s
e
-l A
o : ] - - -
e :
5 g o
Jorys-—_
Cdarcg:
........ e ——
= EELE
ot
Ha i i |
»
1, Fim o -
= Ll T P -
— | s ||
__ N L)

Al (o gad LB Y-V P s
I, Preview in Browser 4 ;5 JFolder List Ceond ;o Lol axio g9, cul, SUSTL -V

(Y=Y J&w) J.HS ul:w‘ <9 ;)5).4 ) 03 r:l:u‘ le.b)‘s oo lie 6‘)-3
s
I [ ]
i R o

Py Bt LT Fon
Frevema 1 froene

[ T

3 ey

('

el o Hiee e
o ]

Pk oo Py,
Coon Publish
L

‘;JjJA o ul'l:t‘-d-i@le;t 9&4“'—\\’ JS.J.}



eSS (551l (sla 8l 55 1 lee dilasy

Yy SharePoint ,153la 5 b LIS : Ll g3
289 &La.lSlJ Ao L)"‘ B ow@ )mUa Y-YA Jiw =9 )fj).o B dawo odalin l) —\‘
72 g i 50 Db 4y adily Wb amio Gnb b carden Bl slean 1 S

Cils aaler 042y o iwd el Lol ol oo 5 plasl 4 Slras 4y IS jeim v

(VA )

' s v
i : S L - r Wi - | i e E

byt g ! ot e
o 15 e

! g gl Ay i gl e i

R9s0 4o plalaiyhi sualiis F-\A JSib

3 LS ailes e 50, 5,lg .0sS 5yls 1y 0g5 LLais 50 sla e Dlio iy yo =YY
Sl ol o lg 1) (s s 5l cenlin yygai diz pglal axan ;o .Cawl Word l53le
Hlg ol 4y T g9, SS9 )l 5l Dype o 5 alil SasS ojlail o b uSe a5yl
I, Auto Thumbnail 4,35 5 08,5 el SCIS Jlais jg0 WSe (55, Gl (B igd jalbs
(Y1 S oS ol

V=Y JS8) ol 8 dsie G o S-S ol o |y uSe gob ol lgi oo LIS 00l L



ke i T . e e '
Sasal g ol g g 503 90 i Sl sy
ekt || M =

a4 S

oy
Syt
g
E=he ybn %
[P da oy
& Pt
|k Bapa Pramerad
Charge Pubies Bie Tyes.
e I
e Fags in N Siredoes
S Lisrdad Rllls e
Picure Pappartien. ..
(il ..

- =l
—
o ¥ ;
B A yuly S
- i i

— I
fiisin T e e e e e s

— |y
. .-n-l-.r.rll-

o

Pobeald (6 I8 d S g8 03ladl Hu o gluald (u gad dSLAI Y=Y IS



SheSS solal slasln8ta 55 1 S ylee dilasy

\vo SharePoint ,153la 5 b LIS : Ll g3

=k Lk 50 pslat 5 e Ly ogs dbde Billas 1) Coluoy (Koo Slrio uﬁ“@
dled 03 g 00,5

File gse 5l Close a8 Ol b ol g axman 0 X cdle (59, SUS L axio j» M«”—ﬁ@
WS bl 1) Close Site 435 File (g9 5l ol g s gl 090 o0 plxl
ol 005 03D joim 4S o 00ld sauan Ol amio ,0 4 Cawl )] Klis asmin b LS 0 F cadle

392 90 51 gSI! 31 ool (g Culw g 214k F-F
L s5lecs 00,900 1y )18 slajLs ples SharePoint jl380s i glagSl alwg 4 >y ol S
W IS Casgd &S syl a4y 5 dalss e dS 1) dz] e Wi dxio S5 0 dalssy )l Col S
olgzds asan olawi 18 w9 0,5 Sbl JB amas b Colucy S ole o0 oo (s oo I )8
eyatte B e S 4 SO e b anil JB aulg e ol o Slris o S wdlsl coll o )

Aol a1y 0e5 4

Ot oS (b 9s3 Gl e AllS Cuz Cale s SG oyl wal 0 558 Y e

ol Bl o guiae dmio LS (B, daxio ol amio SO Jols a5 ol amans F gyl colu o
Lol palai 5 )5 axan g
39800 JW5o i 4 5 Jolie Sole g cnl slml 6l
0d—53b 0,9l 05 jo S Clsesl |, Website 435 New g4 pj g File sg0 51 =)
oy olonl e an gy =l asS Gl | Empty Web Site g, ¢ General a3
(Y=Y USS) 095 anles Lol o glazas o 0 JB cole
aS oo dlgy S s ol o o aS 0ed oo ol ol g SO Folder List L o -Y
JSU ol J31s eyl coliw g ol )0 Glamio (g2 sl oo &od ] 0,033 e
V=YY ) 0sS ool ovalive (5



Crents brev b ohe st nochasg i€,
[ ——— et weh Sie Witad

Tl B b e oo Hee v eiphs e

dadis fons AB Cul 09 S alaal ¥V ik

ads gas Cubw 0 g alaal ¥-YY Jsid



eSS (551l (sla 8l 55 1 lee dilasy

Wy SharePoint ,153la 5 b LIS : Ll g3
g i A el oloul Coliss ] j0 wnas Ao SO eele s o 935S =Y
g9 General goaib 5l ool ol o5l ,0lS jo .00 SIS |, File>New—>Page

Y-YY JSS) 0sS SIS OK daSs (69, (e 9 0,5 Ol |y HTML asas

s
= - T
. ' m Cisls 4 foars HTM, vl 028
A AETT "‘_-! B
| Marer Fale

o ] © D with Famplate

) msnsergd Top-ms
i ek 1]

B Tant Fis
Ty it P

"y raate hom [rprusme; el Tampiate. ..
1'.':tr!lu1|"|nl'ln F e

HTML JSii U sssa dadis (S Ll F-YY Jib

Gy dads jo wian dadis by Y-V S
aao pb aS 0ed oo 5L (slogloe 05 . 0uS LS Standard 13l lgs 5l Save aeSs (g9, -0
g9 Default 53 oy pb o oo |y dxan Glgic g abo 33 Jore dio 45 (o>
V-YO ) asb oo Untitled (6,8 i olgie § WebPages (6,8 i



oMl ol ) 5 Sia 3 eyl @laa 5 8 losl — elaial H sl 5 S ol
58 ety LIS G il als Gl 158055 5,8t laslied als YA
ol dalllas :o jlach Y=YY/YE/N/¥ 0 ylad

L O Lecumendt wed Zemropme ity Decmaeraisly el Shaapputa

Fil i sl il

1! e T i B

w
- Eargm Ho el |

aua dadis 6 Ad F-YO Jsud

Sled ley 10 5 0 Glio b bl )0 axas pb el Ggliss axin lsie b asio o “@

WS o oanline |y o) )54 cl g le asan laie a5 Jl> o o)l 0,8 el

a—po ;o " ol axa " 4, Change ftitle 4 oS> 59, S5 L |y axia o lome —-F

(F-YF JSs)

Fage (i

Y PN

Thas bt of Hea e B chiplesesd inthe HHs B o B e,

I [ ! | Caroal

adis ol gie s V-YF IS
ol e aS 545 e adlol cole 4 aman S Folder List Jib ,o Save aeSs SUSL -V
Hebo dn amio ol g 0418 g al ST ol ] L o )0 g 00ge default.htm

F-VY ) canl oty il Colo wg A aio (lyie 4 (5,3 i



Ladad g3 Causd 4y dadis (add ddldI Y-TY S
S, ..\.",.;ls ply g aps yoss Index 4 | default axas b Lo ol 55 Rename
(Y=YA JS8) aues by Yes

s 75 Py Wk

2l ad Cewlzaif Wacipr Nage

Bleses Promm Buisting Page
W Poeveen i frowie

& 0K
Ay ooy
B Eede

Index a3 Lol dadin als yuadd Y-YA-LAI Jsuds

B il ey b G el "l b, e RO G
ﬁ of i ety s :

e S o | S

Lol dadis als puaas auli Y-YA-G s




ol bl 5 Sia 3 eyl @laa 5 8 losl — elaial H sl 5 S ol
ety LIS G 1 laiticel Al Sl 13055 5a,lS 10 uslieul als

15T aalllas 10 jlach Y-YY/YY/\/Y co,lach

Slgoee Gugs 9 03,5 BLAl Coluwcg @) Hla 3 50 W Slxio wilyi oo gy e L
@diloilu sl (e b sloa iy | Coluog Ay ;0 coal g aaS olnl | Glio
ai ) Dl g gy g sl SIS by S solil o] g0 slodilia 5 g i
Ol 50 0,5 sloul )l g0 1) dxbo g5 co 45 04 o ool aligs s S New—>Folder
A dde S5 g polal (5 )5 axman g o WuSe 0 >3 gl Images sU a4 ddig o5 SO Jlie
Sgs o Sloml LacliS 8 xe g Cugac p,8 axd o 90 0,53 jglaied; Styles b

PR JS)

g alds (o) s Ladad g 43y alaasl Y-Y4 S
=920 dxias dwles sl File 2 New 2 Page s 5l 1) "laoliS 8 x0" axan >
s les oLzl Header, Footer and Contents g, 3 Frames Pages a ol 5l 1, e LS
(Y=Y o) o aalgs adlsl Folder List 4 aio ol oyl 50,5 0,053 5l am
33,5 5o a8Lol Folder List ;o Lol 045 oo adlal Jislyg aman 10 "laolS 3,00" axan
aslsl Folder List ;o axio o] ol i plol amao 0033 Joe a5 Jlojy b a1 >
=YY JS8) wd aalyss

Y.

-4

e

-1



OF (9SS 0,330 Juds ds Laglis S yae dades (judis dSLdl Y- s

Ols=e ¢ Introduction s L 1) "LacleS 8 jae" axan ¢ 0iS SUS Save aaSs 55,1V
(V—Y‘Y J&w) Qoo |) UT B ‘A,.,S °)'.‘.">"> Style duwy B uL;.S GSJAA

s File>New->Page ,...o ;| Image aig ,o |, Photo-Gallery b b yolas s, J5 axan—Y
pyd azio s 18" polai 5 JB | axis laie .0 sbwl HTML ¢4 9 General |
a; Folder List oL 951 .00l slw| HTML g45 g General jl g File>New—>Page
Al Y=Yy s



Gl o g Slads golai ayS dSLSI F-¥Y st



LSS o1l (sla )38l 53 1 3 ylgs dilas
SharePoint ,153la 5 b LIS : Ll g3

WY

Sl s slaeySoT bl .auss™ 5L Folder List 5 )] b (g9, SIS bls L |, Index axao -

L e o950 (Right To Left) o a5 conly Ojg0 0 1) aran ;o e g5 Common

IS8 05l yolS jo Page Properties au 38 bl ciul g aban (9,0 Canl, SIS
A2 bl 1 5L 850 8 lee Y-YF

Garusrald Formrathing - Aadwarasd - Curfom  Lerepags | Workoroup
AOLIEET P POy Tescumants sl Seftrngs Bme iy Doacumants My & I
e skl mka
e deirpial
T 85l i
Dot igar waa™;
Dol i vt Friafes o i
Page Do Eighé-ho-eft
Bahgroaurd sourd
SCn |- Faimrar
Lo F Forevad
|_ El' J ] Cafba

dadin Eilaalii alail (51, 0y glas yals FYYF i
J=B G oles oo Background sound cend jo Page Properties ,slS General 4bj 51-18
508 Fyo bl ol ogdce ST g 155550 50 Ao oS 0 1 s Cuped amio 4 (Jgeo
&S e patiine |y Seo BB gl 1 SG Sleds slows Loop ald ogi |2
S ool dxbo Ao Gleie 4 peal b K SOl aules o Formatting «ib jo V¢
a4 > ol SIS OK awSs (g9, 9 wlsil Background cwend o 1) (lais 00 K,
Ll by LSS, Sl e Sy b bl 05 adej ey S5, ST a5 ail il

V-V JSo) ail aseine diuw) ol 5o e U oS



oMl ol ) 5 Sia 3 eyl @laa 5 8 losl — elaial H sl 5 S ol
58 ety LIS G il als Gl I58la 5 5,8t luilied als YW

15T aalllas 10 yladh Y-YY/YE/\/Y o lads

Gergmnl | Formstting | Advanced | Custom | Language | Soraraun

Eoxch i et
[ Buachgronarad picturs
[(rowme... |
Cistewrs
Eaigrost | [ ¥ ek W ukowrsie =
Tesit: B senpe & wseedbpeink: | B spaeae M

Bartivs beppariing- [ [EEFFETETS =

Heemalyperiehe | [l Bgomaic =

G ol T
i e ——— + G i 5 (L LN R T Y L

]:i]“-:'.
i
|
|
¥
i
S

i“;',i

i1

B e T W

G0y S0y ydd F-YO-o Jsud



eSS (551l (sla 8l 55 1 lee dilasy

Yo SharePoint ,153la 5 b LIS : Ll g3

DS by 1 055 e e olgds slals jo Enter oS 0,28 b il pg azmas o -V
oo ol o ples Alsl axa v a5 pgai Insert o 3l oolatunl b auslys oo
wlgzds LB o Insert sgio 31 (lgi oo iz aBL (S8 Jle colics and wilgs oo

Iy o ¢ ol img 5l 20,5 a8lol colw 4 1) oole] b B ouls b Dlie s>
(Y-YF JSs) asles 0,05

g o 1T g i Tyl ol

e —

| L il s i o i el i i f

Culw 0y ol dadin ¥-VF sk

b amio ol Glp | co oy Caols S L "eugac 03" L Sign-Up axis —VA
aS cel L obbald @ ogac 0,8 gl auS Ol olgsds die) g 9 00,5 Jlesl
= 3l Inputg Text Area, Label .ail oo 59290 aan Cewly Ceows Tool Box o
2 Ngh o el il doas (o Lol 5l oo (g, ST s b osiun ool ]
5 95 o LS dasin O L 4l aS Name aa suin o)l dasin o o] 51 S
Caonnd 4 Slaseiie (ol (Y-TY JS8) 090 ales )] glgioe 45 Value aa seia

Sl oanlie g yss 8 Attributes iz Tag Properties

033 g 009 (Flb 33 addu 4 |, "L OLS Byme" 5" pglal (o5 Db ww@



oMl ol ) 5 Sia 3 eyl @laa 5 8 losl — elaial H sl 5 S ol
438 5y LIS G il als IZS RN USSR RVIL W PN C Y /2
15T aalllas 10 yladh Y-YY/YE/\/Y o lads

s W g RS e g W
e 1w TN N T ILEF OO T T TR

i g

o 1 e

Culs 0 g G gudss p S dadn YTV S
S 6,5 (S b Sl el cog Slran  ohb a5 sg05 o Ll iS5l 4y b (LL o
o b olsl ans his ISasly cpl jo ail ce i 53 ipl j0 a8 assl jl 5 Lake g Hoduss
e a5 e (sl o6 gt 8 sl a3y e g 2o sl 305

II- Learn in English

Open a site from Office SharePoint Designer 2007

To open a SharePoint site, you must have at least the View permission for
that site. This permission is included by default in the Full Control, Design,
Contribute, and Read permission levels. If you don't have the necessary
permission, contact your server administrator.

As an alternative to the following procedure, if you have recently opened the
site, you can point to Recent Sites on the File menu, and then click the site

that you want to open.
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1- On the File menu, click Open Site.
The Open Site dialog box opens.
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By default, the Open Site dialog box opens with Web Sites selected on the

My Places bar and displays all sites that have been opened by using Office
SharePoint Designer 2007.

2- In the Open Site dialog box, do one of the following:

In the large list box, click the site that you want to open, and then
click Open.

In the Site name box, type the URL of the site that you want to open,
and then click Open.

For example, you might type http://My_server/My_site.

Note: No folder or site names appear in the Site name box until you either
start typing or click the arrow.

3- If there is currently another site or file open, the site opens in a new
window.
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10- To create a new website you: (Select all that apply.)
a- File>New—>Page b- File>New—> Website
c- File>Website>New d- File>Page>New
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Tables

Tables are the core database objects. Their purpose is to store information.
The purpose of every other database object is to interact in some manner
with one or more tables. An Access database can contain thousands of tables,
and the number of records each table can contain is limited more by the
space available on your hard disk than by anything else.

Reports

You can display the information recorded in your tables in nicely formatted,
easily accessible reports, either on your computer screen or on paper. A
report can include items of information selected from multiple tables and
queries, values calculated from information in the database, and formatting
elements such as headers, footers, titles, and headings.
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10- Which object do you use to store information on Access?
a- Table b- Query
¢- Macro d- Form

11- Which object do you use to print information on paper?
a- Table b- Query
c¢- Report d- Form
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II‘ Learn in English

e A table is just one of the types of objects that you can work with in
Access. Other object types include queries, forms, reports, pages,
macros, and modules

e Tables are the core database objects. Their purpose is to store
information in Database.

e You can display the information recorded in your tables in nicely
formatted, easily accessible reports, either on your computer screen
Or on paper.

e You can use the Report wizard to get a quick start on a report, but
you will frequently want to modify the resultant report; you can do
this in Design View
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or paper?
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II‘ Learn in English

Create a basic diagram
1- Start Microsoft Office Visio.

When Visio starts, several windows appear. For now, all you need to
work with is the window titled Template Categories.

2- In the Template Categories window, in the list of categories, click the
General category. All the templates in the General category appear in
the central window.

3- Double-click the template titled Basic Diagram.
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Connection points

A connection point is a special point on a shape that you can “glue”
connectors and other shapes to. It looks like a blue x ( ). When you glue a
connector or shape to a connection point, they stay connected, even if one of
the shapes is moved. Use connection points when you want connectors or
shapes to stay connected to specific points on a shape. If the shape you want
to glue a connector or shape doesn’t have a connection point where you want
it, you can add one.
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Attach devices

To attach devices to the Ring Network or Ethernet shape by using the
shape's built-in connectors:

1- Click the Ring Network or Ethernet shape.

2- Place the pointer over a control handle <. When the pointer changes
to a four-headed arrow, drag it to a connection point = on one of the
device shapes.

When the device shape is correctly connected to the Ring Network or
Ethernet shape, the connection point turns red, indicating that it is glued.
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II- Learn in English

Set a primary key

Relationships use primary and foreign keys to map rows in one table to
corresponding rows in another table. At least one of the tables in the
relationship must have a primary key in order to establish a relationship.

1- Double-click the table in your diagram.

2- In the Database Properties window, under Categories, click
Columns.

3- Select the PK box for the column for which you want to use a
primary key.
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A use case diagramis a diagram that shows the external actors who will
interact with your system and how they will use it. The diagram consists of a
system boundary, actors, use cases, and use case relationships.
(communicates, uses, and extends) In a use case diagram, the communicates

relationship "= defines how an actor participates in a use case.
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5- Office Visio 2007 step by step, Microsoft, 2007
6- Office OneNote 2007 step by step, Microsoft, 2007
7- www. OpenOffice.org
8- www. Office. Microsoft.com / home
9- Microsoft Office Access 2007 Help
10- Microsoft Office Visio 2007 Help
11- Microsoft Office OneNote 2007 Help
12- Microsoft Office SharePoint Designer 2007 Help

13- Debbie, walkowski. Visio 2003 For Dummies c, New York, Wiley publishing,
2007





