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A database is a tool for collecting and organizing information.

Databases can store information about people, products, orders, or

anything else. Many databases start as a list in a word-processing program

or spreadsheet. As the list grows bigger, redundancies and inconsistencies
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begin to appear in the data. The data becomes hard to understand in list
form, and there are limited ways of searching or pulling subsets of data
out for review. Once these problems start to appear, it's a good idea to
transfer the data to a database created by a database management system
(DBMYS), such as Office Access 2007.

The design process

The design process consists of the following steps:

eDetermine the purpose of your database: This helps prepare you for
the remaining steps.

oFind and organize the information required: Gather all of the types
of information you might want to record in the database, such as product
name and order number.

eDivide the information into tables: Divide your information items
into major entities or subjects, such as Products or Orders. Each subject
then becomes a table.

eTurn information items into columns: Decide what information
you want to store in each table. Each item becomes a field, and is displayed
as a column in the table. For example, an Employees table might include
fields such as Last Name and Hire Date.

eSpecify primary keys: Choose each table’s primary key. The primary
key is a column that is used to uniquely identify each row. An example might
be Product ID or Order ID.

oSet up the table relationships: Look at each table and decide how the
data in one table is related to the data in other tables. Add fields to tables
or create new tables to clarify the relationships, as necessary.

eRefine your design: Analyze your design for errors. Create the tables
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and add a few records of sample data. See if you can get the results you
want from your tables. Make adjustments to the design, as needed.

e Apply the normalization rules: Apply the data normalization rules to
see if your tables are structured correctly. Make adjustments to the tables, as

needed.
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Create a new table
A simple database, such as a contact list, might use only a single table.

Many databases, however, use several tables. When you create a new

database, you create a new file on your computer that acts as a container

for all of the objects in your database, including your tables.

You can create a table by creating a new database, by inserting a

table into an existing database, or by importing or linking to a table from

another data source — such as a Microsoft Office Excel 2007 workbook,

a Microsoft Office Word 2007 document, a text file, or another database.

When you create a new blank database, a new empty table is automatically

inserted for you. You can then enter data to start defining your fields.
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Create a new table in a new database
1- Click the Microsoft Office Button , and then click New.
2- In the File Name box, type a file name. To change the location, click
the folder icon to browse.
3- Click Create.
The new database is opened, and a new table named Table is created

and opened in Datasheet view
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Export data to Word

The process of exporting data to a Word document follows these broad

steps:
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e Prepare your source data for the export. As part of this step, you
make sure that your data does not contain errors, and you decide whether
to export some or all of the data in your source table.

e Run the Export Wizard.

e Optionally save your settings as an export specification for later
reuse.

The steps in the following sections explain how to perform each
task. Prepare for the export

1- Open the source database.

2-In the Navigation Pane, select the object that contains the data you
want to export.

3-You can export a table, query, form, or report.

4-Review the source data to ensure that it does not contain error
indicators (green triangles) or error values, such as #Num.

Ensure that you have resolved any errors before you export the data
to Word. Otherwise, you will find that such values are replaced with a
null value.

5-If the destination Word document exists and is open, close it
before you continue. The wizard prompts you before overwriting the
document.

NOTE You cannot append data to an existing Word document.

6-In the database, if you want to export only a portion of a table, query,
or form, open the object and select just the records you want.

Export the data

1- On the External Data tab, in the Export group, click Word.
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NOTE The Export commands are available only when a database is
open.

2- In the Export Wizard, specify the name of the destination file.

3- The wizard always exports formatted data. If you want to view the
Word document after the export operation is complete, select the Open
the destination file after the export operation is complete check box.

4- If you selected the records that you want to export before you
started the export operation, you can select the Export only the selected
records check box. However, if you want to export all the records in the
view, leave the check box cleared.

NOTE This check box appears unavailable (dimmed) if no
records are selected.

5- Click OK.

6- If the destination document exists, you are prompted to click Yes
to overwrite the file. Click No to change the name of the destination file,
and then click OK again.

Access exports the data and opens the destination document in Word,
depending on the export options you specified in the wizard. Access also
displays the status of the operation on the final page of the wizard. Go to
the next steps if you want to save your import settings for later reuse.
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Create and run an update query

The safest way to use an update query is to first create a select query
that tests your selection criteria. For example, suppose that you want to
update a series of Yes/No fields from No to Yes for a given customer. To
do so, you can add criteria to your select query until it returns all of the
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recordsCreate and run an update query

The safest way to use an update query is to first create a select query
that tests your selection criteria. For example, suppose that you want to
update a series of Yes/No fields from No to Yes for a given customer. To
do so, you can add criteria to your select query until it returns all of the
records that contain No in the records for that customer. When you are
sure that the query returns the correct records, you then convert it to an
update query, enter your update criteria, and then run the query to change
the selected values. The steps in this section explain how to create a select
query and then convert it to an update query.

Create a select query

1- Open the database that contains the records you want to update.

2- On the Create tab, in the Other group, click Query Design.

The query designer opens, and the Show Table dialog box opens.

3- Select the table or tables that contain the records you want to update,
click Add, and then click Close.

The table or tables appear as one or more windows in the query
designer, and the windows list all the fields in each table. This figure
shows the query designer with a typical table.

4- Double-click the fields that you want to update. The selected fields
appear in the Field row in the query design grid.

You can add one table field per column in the query design grid.

To add all the fields in a table quickly, double-click the asterisk (*) at
the top of the list of table fields. This figure shows the query design grid
with all fields added.
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5- Optionally, you can enter one or more criteria in the Criteria row of
the query design grid.

6- On the Design tab, in the Results group, click Run.

Verify that the query returns the records that you want to update. As
needed, you can select fields you don't want included in the query design
and press DELETE to remove them. In addition, you can drag additional
fields to the query design grid.

7- Go to the next steps.

Update records

1-On the Design tab, in the Query Type group, click Update.

This procedure shows how to change the select query to an update
query. When you do so, Access adds the Update to row in the query
design grid. The following illustration shows an update query that returns
all assets purchased after January 5, 2005 and changes the location to
"Warehouse 3" for all records that meet that criterion.

2-Locate the field that contains the data you want to change, and
type your expression (your change criteria) in the Update to row for that
field.

You can use any valid expression in the Update to row.

3-On the Design tab, in the Results group, click Run.

An alert message appears.

4-Click Yes to run the query and update the data.

Note When you run the query, you might notice that some fields are
missing from your result set. If your query contains fields that you don’t
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update, Access does not display those fields in the results, by default.

For example, you might include ID fields from two tables to help ensure
that your query returns and operates on the correct records. If you don’t
update those ID fields, Access does not display them in the results.
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Insert a datasheet into an existing form by using Design view

Use this procedure to add a datasheet that is based directly on a table
or query to an existing form in Design view.

1- Open the form in Design view by right-clicking the form in the
Navigation Pane, and then clicking Design View.

2- On the Design tab, in the Controls group, if the Use Control tool
is selected, click it so that it is not selecteWhy?

If used, the subform Control Wizard builds a separate form object and
bases the subform control on that form object. By contrast, this procedure
creates a datasheet that is based directly on a table or query

rather thana form.

3- On the Design tab, in the Controls group, click the Subform/
Subreport tool.

4- In the form design grid, click where you want the datasheet to be
inserted.

5- Reposition and resize the subform control by dragging the handles
on the edges and corners of the control.

6- Edit the attached label for the subform control by first clicking the
label, double-clicking it to select its text, and then typing a new label.

7- If you prefer to delete the label, click the label once and then press
DELETE.

If the property sheet is not already displayed, press F4.

8- If the subform control is not currently selected, click it once to
select it.

9- On the Data tab of the property sheet, click the Source Object
drop-down list, and then click the table or query that you want to display
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in the datasheet. For example, if you want to display data from the Orders
table, click Table.Orders.

10 - If you set up the relationships correctly before you started this
procedure, Access automatically sets the Link Child Fields and the Link
Master Fields properties with the correct values that will link the main
form to the datasheet.

My Link Child Fields and Link Master Fields properties are blank

If Access cannot determine how to link the subform control to the main
form, it leaves the Link Child Fields and Link Master Fields properties
of the subform control blank. You must set these properties manually by
doing the following:

1- Open the main form in Design view.

2- Click the subform control once to select it.

3- If the property sheet is not currently displayed, press F4.

4- On the Data tab of the property sheet, click (...) next to the Link
Child Fields property box.

The Subform Field Linker dialog box appears.

5- In the Master Fields and Child Fields drop-down lists, select the
fields that you want to link the forms with. If you are not sure which
fields to use, click Suggest to have Access determine the linking fields.

When you finish, click OK.

If you do not see the field that you want to use to link the forms, you
might need to edit the record source of the master or child form to be sure
the field is in it. For example, if the form is based on a query, be sure the
linking field is present in the query results.
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6- Save the main form and switch to Form view to verify that the form
works as you expect.

11- Save the form by clicking Save on the Quick Access Toolbar or
by pressing CTRL+S.

12. Switch to Form view (Form view: A window that displays a form
to show or accept data. Form view is the primary means of adding and

modifying data in tables. You can also change the design of a form in this

view.) and verify that the datasheet works as you expect
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Create a macro group

If you want to group several related macros in one macro object, you
can create a macro group.

1- On the Create tab, in the Other group, click Macro. If this
command is unavailable, click the arrow beneath either the Module or
the Class Module button, and then click Macro.

The Macro Builder is displayed.

2- On the Design tab, in the Show/Hide group, click Macro Names
if it isn’t already selected.

The Macro Name column is displayed in the Macro Builder.

NOTE In macro groups, macro names are necessary to distinguish
the individual macros from each other. The macro name appears on the
same line as the macro’s first action. The macro name column is left
blank for any subsequent actions in the macro. The macro ends when the
next macro name is encountered.

3- In the Macro Name column, type a name for the first macro in the
macro group.

4- Add the actions that you want the first macro to carry out:

In the Action column, click the arrow to display the action list.

Click the action that you want to use.

Under Action Arguments, specify arguments for the action, if any are
required.

To see a short description of each argument, click in the argument box,
and then read the description on the right side of the argument
5- Move to the next empty row, and then type a name for the next
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macro in the Macro Name column

6- Add the actions that you want the macro to carry out

Repeat steps @ and 7 for each macro in the macro group

The following illustration shows a small macro group. The macro
group contains two macros, the names of which are displayed in the
Macro Name column. Each macro contains two actions.
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Use a database password to encrypt a database

The encryption tool in Office Access 2007 combines and improves

on two older tools — encoding and database passwords. When you use a
database password to encrypt a database, you make all data unreadable by
other tools, and you force users to enter a password to use the database.
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The encryption applied in Office Access uses a stronger algorithm than
was used in earlier versions of Access

Encrypt by using a database password

1- Open the database that you want to encrypt in Exclusive mode.

Open the database in Exclusive mode:

A- Click the Microsoft Office Button, and then click Open

B- In the Open dialog box, browse to the file that you want to open,
and then select the file.

C- Click the arrow next to the Open button, and then click Open
Exclusive.

2- On the Database Tools tab, in the Database Tools group, click
Encrypt with Password .

The Set Database Password dialog box appears

3- Type your password in the Password box, and then type it again in
the Verify field.

NOTE

Use strong passwords that combine uppercase and lowercase letters,
numbers, and symbols. Weak passwords don’t mix these elements. Strong
password: Y 7dhleto. Weak password: House27. Passwords should be 8 or
more characters in length. A pass phrase that uses 14 or more characters is
better. It is critical that you remember your password. If you forget your
password, Microsoft cannot retrieve it. Store the passwords that you write
down in a secure place away from the

information that they help protect.

4- Click OK.
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Decrypt and open a database

1- Open the encrypted database as you typically open any other

database.

The Password Required dialog box appears.

2-Type your password in the Enter database password box, and then
click OK.

Remove a password

1- On the the Database Tools tab, in the Database Tools group, click
Decrypt Database.

2-The Unset Database Password dialog box appears

3- Type your password in the Password box, and then click Ok



oals olf.:l; w)m.\.o

REIA NI Jge s il oS

Sl e g g A5 el By o e 5] o5 LSl S 5l e Lablne
B, ol )l S S8 Ay ol plowl s sty 45 el (gl ST el S|
3l jle b lpl ol 0 Sgus ogllas 956 au b ] 5 plaS 2 5l g5 e aST el 00,8
531y 570 (518 LI Sy 6 335 o o 45 e 5 (6o i
A e g8, 1y o] i (glallas 5 asS Uil S
SR Gl Sl LB (sl (ISt 550 050 50 0T ai b oS (6 S bty
BRIV PE
sy o SEM] STl 4y jlne d ol 8wl 3l s 45 0319,05 L (5,105 30,
Aol aslas
il Osle i8S 18 (s 0 90 Jad (nl )0 4 (6503 05
elmslys i 5 S e oo | LSl (Sl (gl b ol g Jpr 45 (6 3 Lovinte
a3 oo )l Wi &35 5 iludle s sl |,
Sk (b b gam Sl Jloel jo 1) (ol gars (4 b oS (g5l
A oo SaS wyas Sledlbsl Q¥
sy g aS colaiul Sledsl UL 51 (Sole 4y 1,15 058 co o 45 O pgmad g

S calaa ol gyl a4



SO Sl 5l cladlon o o Ulgs

Pl o1 sl 1) s 0l9e g 9 o i o 1) (g 5 OLS Sy Sledlol Sl )
A2

S s 1, o Jgaer (A

DS s pleidy (Sledlbl SOl (e

DS ey |y SO S slos o3 ) (o

DS A |y Sledbol SOL wlasis (o

S cliblons o, b1, Sledbl b (&

0S sl Sl SOl gl S s o (2

§cw> Navigation Pane ¢ Switchboard .o &gles .Y

Cans o plool SM! Sol (55, shos 4z (g3loos b Y

S oo g luniine SOOI SOl 1> F

05,5 ayl dz MLl il Sy (503l5,38 i (gl O

ARYA



0dld olf.sl; w)JM

RSN VYT ge s lailiw] oS

&bw
Sl Ll (2955l Sy, o8 dezte Sy 5 dmosls ol sl i lie -
o5l
5 ple oEiils ozl g 5> blaas 1155 (60,5 code el SSL-Y
3-An introduction to Database — Date, C.J — McGrawHill — 8 ed.
4-Teach Yourself Visually Access 2007 — Wempen, Faithe — SAMS
5-Access 2007 Complete Reference — John Leonie, Margaret Leonie
Yang
6-Microsoft SQL Server 2008 (A Beginner’s Guide) - Dusan Petkovic
— McGraw Hill-2009
7-Introducing Microsoft SQL Server 2008 —Peter DeBetta, Greg Low,
Mark Whitehorn — Microsoft — 2009
8-SQL Fundamentals — Third Edition — John J. Patrick — Prentice Hall
- 2009
9-Beginning SQL Server 2008 for Developer: From novice to

Professional — Dewson Robin- Apress

3

\hYd



